Archive for January, 2009

WPrinter 3.1 registration issues/changes

Just wanted to mention few things about registering WPrinter 3.1.

If you use Windows Vista with UAC turned on, or if you’re in the corporate environment with limited Windows user privileges, you can find yourself having trouble registering WPrinter. You could receive the following error message attempting to register WPrinter with a valid registration key: “You must have Administrator’s permissions to register WPrinter. Registration failed.”. This is due to WPrinter requiring access to part of Windows registry that’s normally reserved for administrators or power users and is normal behavior, a.k.a. requiring administrator permissions. Registration is the only time when such permissions are needed.

Here’s how you can work around it. Close WPrinter so that it’s no longer shown in the system tray. Find WPrinter installation folder (typically \USysWare\WPrinter). Right click on WPrinter.exe and select ‘Run as administrator’ menu item. On Vista you’ll be prompted with a UAC dialog. Allow it to run and try registering WPrinter again. Once that’s done, close WPrinter again and re-start it from its installation group to allow it to run with default user permissions. Verify that it’s still registered by checking ‘Help’|'About WPrinter’ menu item. That should take care of the problem.

And as I mentioned before, all features in version 3.1 should function the same exact way compared with version 3.0. The only known issue is that version 3.0 registration information is not compatible with version 3.1. The workaround is very simple: just re-enter your registration information after installing the new version 3.1, keeping in mind the above information regarding registration and administrator permissions.

Hope this helps.

Sergey @ USysWare

WPrinter 3.1 (build 114) released

We are pleased to announce general availability of new WPrinter version 3.1. The primary goal of this release is to address some known Windows Vista and Server 2008 compatibility issues, and add native support for 64-bit Windows versions.

While this version introduces no new major features, it marks an important milestone - it is based on Microsoft .NET 2.0. Old WPrinter 3.0 version was not based on .NET.

All features in version 3.1 should function the same exact way compared with version 3.0. The only known issue is that version 3.0 registration information is not compatible with version 3.1. The workaround is very simple: just re-enter your registration information after installing the new version 3.1.

Please note that minimum system requirements for .NET 2.0 start with Windows 2000. Thus, Windows 95, 98, ME and NT 4.0 are no longer supported. You can continue using WPrinter 3.0 if you require compatibility with the above mentioned operating systems. Please use the following link to download .NET 2.0 SP1 runtime.

Here is the short list of new features introduced in WPrinter version 3.1:

  • Full Windows Vista support.
  • Native 64-bit Windows support.
  • Windows Vista UAC and non-administrator improvements.

The new version is available at http://www.usysware.com/downloads.aspx. Enjoy.