File Browser Not Finding CSS Files for 2010

Post general DPack questions or problem reports here.

Moderator: Sergey

File Browser Not Finding CSS Files for 2010

Postby bwood » February 22nd, 2010, 3:51 pm

Current version for 2010 RC1 (I think it was just released in the past day or 2?) doesn't seem to find .css files whereas previous versions did. Previous version for 2010 Beta2 didn't either.
bwood
Junior Member
 
Posts: 9
Joined: February 22nd, 2008, 7:34 pm

Re: File Browser Not Finding CSS Files for 2010

Postby Sergey » February 22nd, 2010, 11:58 pm

You need to make sure that "Show All Files" (right most one) option is selected. It's not selected by default filtering out any non-code files, including files like .css.

HTH.
Sergey @ USysWare
User avatar
Sergey
Moderator
 
Posts: 556
Joined: May 27th, 2005, 3:56 pm
Location: Alexandria, VA

Re: File Browser Not Finding CSS Files for 2010

Postby bwood » February 23rd, 2010, 11:26 am

Sergey wrote:You need to make sure that "Show All Files" (right most one) option is selected.
HTH.


Is this a DPack option, or a VS option? Can't find it in DPack options, and the "show all files" toggle on the solution explorer window doesn't affect it.
bwood
Junior Member
 
Posts: 9
Joined: February 22nd, 2008, 7:34 pm

Re: File Browser Not Finding CSS Files for 2010

Postby Sergey » February 23rd, 2010, 11:33 am

Sorry, I should've been a bit more explicit. Correct, it's a DPack option. It's on File Browser dialog's toolbar.
Sergey @ USysWare
User avatar
Sergey
Moderator
 
Posts: 556
Joined: May 27th, 2005, 3:56 pm
Location: Alexandria, VA

Re: File Browser Not Finding CSS Files for 2010

Postby dnk.nitro » May 18th, 2010, 3:17 pm

After installing 3.0.1 version for 2008 I am experiencing similar problem:
It works fine for "all files" if those files are within some solution's project. E.g. for files like settings.include.

BUT if there is a "solution folder" with some files in it - DPack doesn't show those files in the file browser (even with "show all files" turned on). Please note, that in previous versions this worked very well.

Please fix this as this is very important. Thanks for the great product!

I have Visual Studio 2008 and DPack 3.0.1.
dnk.nitro
Member
 
Posts: 17
Joined: December 21st, 2006, 11:48 am

Re: File Browser Not Finding CSS Files for 2010

Postby Sergey » May 18th, 2010, 4:38 pm

Post a screenshot of your Solution Explorer please with file in question shown in the expanded tree, with the path to the Solution Folder shown as well. This way I can see what you guys are talking about cause I haven't been able to reproduce it here.
Sergey @ USysWare
User avatar
Sergey
Moderator
 
Posts: 556
Joined: May 27th, 2005, 3:56 pm
Location: Alexandria, VA

Re: File Browser Not Finding CSS Files for 2010

Postby dnk.nitro » May 18th, 2010, 4:51 pm

Here you go. On the attachment folders "SolutionCommon", "SolutionCommon\Config", "SolutionCommon\db", "SolutionCommon\Deployment" are "virtual" and are used to logically group files from any folder on the disk.
Attachments
2010-05-18_15-49_#2_-_UsyswareFileBrowser.jpg
DPack File Browser
2010-05-18_15-49_#2_-_UsyswareFileBrowser.jpg (16.22 KiB) Viewed 7053 times
2010-05-18_15-43_#1_-_LancelotMicrosoftVisualStudio.jpg
Solution with "Solution Folder and some files"
2010-05-18_15-43_#1_-_LancelotMicrosoftVisualStudio.jpg (78.55 KiB) Viewed 7053 times
dnk.nitro
Member
 
Posts: 17
Joined: December 21st, 2006, 11:48 am

Re: File Browser Not Finding CSS Files for 2010

Postby Sergey » May 18th, 2010, 10:32 pm

It should be fixed now in the new beta v3.0.2.3 I've just uploaded. Please give it a try and let me know how it works for you:

http://www.usysware.com/files/DPackSetup2008Beta.exe - for VS 2008, 843Kb
http://www.usysware.com/files/DPackSetup2010Beta.exe - for VS 2010, 863Kb

Check out changelog for the complete list of changes. Thanks.
Sergey @ USysWare
User avatar
Sergey
Moderator
 
Posts: 556
Joined: May 27th, 2005, 3:56 pm
Location: Alexandria, VA

Re: File Browser Not Finding CSS Files for 2010

Postby dnk.nitro » June 17th, 2010, 2:19 pm

Thanks! You do really awesome work!

Yes, now it works for solution folders/subfolders. However, it works only in "Show all files" mode. If I turn off that mode, but have some extensions configured in the "File types to always show", those files still are missing. But are shown for "real" solution projects.

If you need more details/explanation on this issue - let me know.

Btw, is there an option to be notified of new post in the thread you started/left replies? That would be really handy.

Thanks again!
dnk.nitro
Member
 
Posts: 17
Joined: December 21st, 2006, 11:48 am

Re: File Browser Not Finding CSS Files for 2010

Postby Sergey » June 17th, 2010, 8:46 pm

dnk.nitro wrote:Btw, is there an option to be notified of new post in the thread you started/left replies? That would be really handy.


I have the latest phpBB installed on the server. The product supports notifications out of the box. When replying or posting there should be a check box below the Submit button, which would say something like 'Notify me when a reply is posted'. There is also a 'Subscribe topic' link at the bottom of the thread.

I personally always get email notifications just fine. If you are setup correctly then it could be that emails get flagged as Spam perhaps.
Sergey @ USysWare
User avatar
Sergey
Moderator
 
Posts: 556
Joined: May 27th, 2005, 3:56 pm
Location: Alexandria, VA

Re: File Browser Not Finding CSS Files for 2010

Postby Sergey » June 17th, 2010, 10:07 pm

dnk.nitro wrote:Thanks! You do really awesome work!


Thanks! I appreciate it. 8)

dnk.nitro wrote:Yes, now it works for solution folders/subfolders. However, it works only in "Show all files" mode. If I turn off that mode, but have some extensions configured in the "File types to always show", those files still are missing. But are shown for "real" solution projects.


Yeah, I see it too now that you mentioned it. I went too restrictive and applied my patch to the problem you originally reported to "Show all files" mode only. Should be fixed now. Give new beta 3.4.0.1 a shot and see how it works for you.

http://www.usysware.com/files/DPackSetup2008Beta.exe - for VS 2008, 841Kb
http://www.usysware.com/files/DPackSetup2010Beta.exe - for VS 2010, 861Kb

Thanks.

PS See my previous reply too.
Sergey @ USysWare
User avatar
Sergey
Moderator
 
Posts: 556
Joined: May 27th, 2005, 3:56 pm
Location: Alexandria, VA

Re: File Browser Not Finding CSS Files for 2010

Postby dnk.nitro » June 17th, 2010, 11:06 pm

I've just tried it and it works. Thanks!
dnk.nitro
Member
 
Posts: 17
Joined: December 21st, 2006, 11:48 am

Re: File Browser Not Finding CSS Files for 2010

Postby dnk.nitro » June 22nd, 2010, 12:32 pm

In that beta I've just received the error when tried to navigate to file in the file browser (VS2008 SP1):
Code: Select all
11:25:16.017  *** Start logging ***
11:25:16.017  Date: 1/26/09
11:25:16.017  Version: 2.8.8.0
11:25:16.017  Runtime: 2.0.50727.3053 SP2
11:25:16.017  IDE: 9.0.21022
11:25:16.017  OS: Windows XP Service Pack 3 (5.1.2600.196608)
11:25:16.049  Error processing selection.
11:25:16.049  Exception information:
  System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
   at EnvDTE.Document.Activate()
   at USysWare.Drivers.FileBrowser.CodeModel.ActivateWindow(FileElement element, Boolean alternativeView)
   at USysWare.Drivers.FileBrowser.CodeModel.ProcessItem(FileElement element, Boolean mustActivate, Boolean alternativeView)
   at USysWare.Drivers.FileBrowser.FileBrowserControl.ProcessSelection()

...
...

11:28:26.896  UpdateResultsList - begin
11:28:26.912  UpdateResultsList - end
11:28:26.912  Update - end
11:28:31.303  Error processing selection.
11:28:31.303  Exception information:
  System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
   at EnvDTE.Document.Activate()
   at USysWare.Drivers.FileBrowser.FileCodeModel.ActivateWindow(FileElement element, Boolean alternativeView) in c:\Users\Sergey\Documents\Visual Studio 2008\Projects\DPackVSIP2008\DPack\Drivers\FileBrowser\FileCodeModel.cs:line 349
   at USysWare.Drivers.FileBrowser.FileCodeModel.ProcessItem(FileElement element, Boolean mustActivate, Boolean alternativeView) in c:\Users\Sergey\Documents\Visual Studio 2008\Projects\DPackVSIP2008\DPack\Drivers\FileBrowser\FileCodeModel.cs:line 311
   at USysWare.Drivers.FileBrowser.FileBrowserControl.ProcessSelection() in c:\Users\Sergey\Documents\Visual Studio 2008\Projects\DPackVSIP2008\DPack\Drivers\FileBrowser\FileBrowserControl.cs:line 180
dnk.nitro
Member
 
Posts: 17
Joined: December 21st, 2006, 11:48 am

Re: File Browser Not Finding CSS Files for 2010

Postby Sergey » June 22nd, 2010, 8:09 pm

Are you sure you looking at the right log? Look at the date/version/IDE/etc. :) FTR, beta I posted is v3.0.4.1.

dnk.nitro wrote:In that beta I've just received the error when tried to navigate to file in the file browser (VS2008 SP1):
Code: Select all
11:25:16.017  *** Start logging ***
11:25:16.017  Date: 1/26/09
11:25:16.017  Version: 2.8.8.0
11:25:16.017  Runtime: 2.0.50727.3053 SP2
11:25:16.017  IDE: 9.0.21022
11:25:16.017  OS: Windows XP Service Pack 3 (5.1.2600.196608)
Sergey @ USysWare
User avatar
Sergey
Moderator
 
Posts: 556
Joined: May 27th, 2005, 3:56 pm
Location: Alexandria, VA

Re: File Browser Not Finding CSS Files for 2010

Postby dnk.nitro » June 22nd, 2010, 8:48 pm

Yes, you are right, I took the log from the very beginning of the file. I think I copied the correct exception details (from the end of the log), but took the environment details from the beginning of the log.

Here you go:

Code: Select all
11:28:31.303  Error processing selection.
11:28:31.303  Exception information:
  System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
   at EnvDTE.Document.Activate()
   at USysWare.Drivers.FileBrowser.FileCodeModel.ActivateWindow(FileElement element, Boolean alternativeView) in c:\Users\Sergey\Documents\Visual Studio 2008\Projects\DPackVSIP2008\DPack\Drivers\FileBrowser\FileCodeModel.cs:line 349
   at USysWare.Drivers.FileBrowser.FileCodeModel.ProcessItem(FileElement element, Boolean mustActivate, Boolean alternativeView) in c:\Users\Sergey\Documents\Visual Studio 2008\Projects\DPackVSIP2008\DPack\Drivers\FileBrowser\FileCodeModel.cs:line 311
   at USysWare.Drivers.FileBrowser.FileBrowserControl.ProcessSelection() in c:\Users\Sergey\Documents\Visual Studio 2008\Projects\DPackVSIP2008\DPack\Drivers\FileBrowser\FileBrowserControl.cs:line 180
11:33:39.055  *** Stop logging ***

11:34:02.711  *** Start logging ***
11:34:02.711  Date: 6/22/10
11:34:02.711  Version: 3.0.4.1
11:34:02.711  Runtime: 2.0.50727.3082 SP2
11:34:02.711  IDE: 9.0.30729
11:34:02.711  OS: Windows XP Service Pack 3 (5.1.2600.196608)
11:34:02.711  Process Id: 4104
11:34:02.711  Beta: expires on 8/2/2010
dnk.nitro
Member
 
Posts: 17
Joined: December 21st, 2006, 11:48 am

Next

Return to DPack Support

Who is online

Users browsing this forum: No registered users and 0 guests

cron